Degraded analytics processing

Incident Report for Vimeo

Update

We have implemented the fix and we are currently monitoring our services.
Posted Dec 04, 2025 - 20:35 EST

Update

A processing issue is delaying analytics data. Previously processed data is still available through the analytics reports. No data loss is projected.
Posted Dec 04, 2025 - 13:14 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 04, 2025 - 13:02 EST
This incident affects: Live Analytics and VOD Analytics.