Degraded Video Analytics data freshness

Incident Report for Vimeo

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 11:21 EDT

Update

Processing of all new video analytics data has been restored as of September 24th, 12:00 PM EDT. We are now processing the backlog of data from September 18th to September 24th. All data is safe and will be made available once the backlog is cleared.
Posted Sep 26, 2025 - 10:37 EDT

Update

Current Status: detected
Current Action: We have identified a delay in processing non-live video analytics. No data has been lost, and all analytics will be fully updated once processing completes.
Posted Sep 22, 2025 - 09:48 EDT

Investigating

We are currently investigating this issue.
Posted Sep 22, 2025 - 09:38 EDT
This incident affected: VOD Analytics.