Increased Error Rates

Incident Report for Vimeo

Resolved

This incident has been resolved. All systems have returned to normal status.
Posted Jun 02, 2025 - 13:28 EDT

Update

Error rates have returned to normal levels, but there are some delays related to video and transcript processing which will be alleviated shortly as those systems catch up.
Posted Jun 02, 2025 - 12:22 EDT

Monitoring

Mitigating measures have been successful. We will continue to monitor.
Posted Jun 02, 2025 - 12:14 EDT

Identified

We have identified the issue and are deploying mitigating measures.
Posted Jun 02, 2025 - 12:08 EDT

Investigating

We are currently investigating an issue with increased error rates on vimeo.com
Posted Jun 02, 2025 - 10:55 EDT
This incident affected: Website and API.